cancel
Showing results for 
Search instead for 
Did you mean: 
Cancel

Help Community

Announcements
Yahoo Help Community is also available in 中文 (Chinese), Français (French), Deutsch (German), and Español (Spanish).

IMAP/POP not working

SOLVED
'Hoo Recruit

IMAP/POP not working

I'm at my wits end here.  No matter what settings I confirm or change, I continually cannot log into my main Yahoo email account via the Android Mail app.  I have tried both IMAP and POP, always get the same "Incorrect username or password, or POP3/IMAP access is not turned on for this account. 
In my Yahoo account settings, third party app access IS and always has been turned ON.  This account has worked on this phone (with IMAP) forever, but now I cannot access it no matter what port I select.  My other Yahoo account still works just fine, it is NOT something I have changed in Yahoo nor the phone. 
PLEASE HELP

1 ACCEPTED SOLUTION

Accepted Solutions
Established 'Hoo

Re: IMAP/POP not working

Here's what worked for me.

Go to outlook-->File-->Info-->Account Settings. Hit New, or click on the account you wish to modify. See at the bottom where it says "logon information-->Password"? Yahoo is rejecting your Yahoo Password! You need to generate an "app-specific password" to pass the first phase of the pop3 handshake. See below....

 

There are two phases to the pop3 test process. 

1) Log onto incoming mail server (POP3)

 

I got this to work by generating an app-specific password. I generated the password by enabling two-factor authentication (where Yahoo sends you a text message):

https://forums.yahoo.net/t5/Temporary-Errors/App-specific-password/m-p/115826#U115826

NB There is a bug, not sure if major or minor: When you generate a password for Outlook 2013 Desktop, it says the password was generated for Outlook Android. But it works for pop3 login (this phase).

 

2) Send test e-mail message:

I couldn’t get this to work til I input the following exact settings. Many of them are similar to the online recommendations but I had to get them exactly right:

 

(Notes: Windows 8.1 PC, 64-bit, Outlook 2013)

 

Pop and IMAP settings window

account type: pop3

Incoming mail server: pop.mail.yahoo.com

Outgoing mail server: smtp.mail.yahoo.com

User name: I just put the prefix, i.e. if your yahoo id is “me  at  yahoo  dot  com”, just put "me". No quote marks ;^D

Password: This is the app-specific (Outlook) password Yahoo Security generated for you in phase 1) above

Remember Password: Check

Require logon using Secure Password Authentication (SPA): Check

Automatically test account settings when Next is clicked: Check

Deliver new messages to: New Outlook Data File

(NB this is for me, setting up a NEW Pop3 account. Might be different if you're trying to fix an OLD Pop3).

 

Now click "More Settings" in lower right to open up the "Internet Email Settings" window. 

Outgoing Server tab:

My outgoing server (SMTP) requires authentication: Check

Log on using: Check

User Name: Full email address

Password: Use that third-party password again.

Remember Password: Check

Require Secure Password Authentication (SPA): Check

Log on to incoming mail server before sending mail: Do not check

 

Advanced tab:

Incoming server (POP3): 995

This server requires an encrypted connection (SSL): Check

Outgoing server (SMTP): 587

Use the following type of encrypted connection: Auto

Leave a copy of messages on the server: Check

Remove from server after xx days: Check

 

Some of these settings don't matter, but I have slavishly attempted to replicate EXACTLY what I did to get it to work. 

Main thing is to enable the 3rd party password in phase 1) above. That will log you into the POP server, then you can tweak the rest and solve phase 2).

 

8 REPLIES
'Hoo Recruit

Re: IMAP/POP not working

Now this morning IMAP is working again.  This is not the first time this random inability to accept my login has happened, for this one singular account.  Extremely aggravating as it naturally happens to be my main email address.  Process of elimination sure seems to point towards something on the Yahoo side of things that causes this, since other accounts using the same settings on the same device have had zero problems.

'Hoo Recruit

Re: IMAP/POP not working

Now two days later, not working again.  Really starting to test my nerves, c'mon Yahoo what the heck!!!

'Hoo Recruit

Re: IMAP/POP not working

I am having the same issues... please let me know if you have found resolve?

'Hoo Recruit

Re: IMAP/POP not working

its not singular to andoid, thunderbird is having the same issue... hopefully Yahoo is still supporting IMAP????

Established 'Hoo

Re: IMAP/POP not working

I'm having exactly the same issue. I wonder if it's related to Verizon's takeover of Yahoo!?

Pro 'Hoo

Re: IMAP/POP not working

I'm sure it doesn't help, but I'm experiencing the same thing here. One account wouldn't sync on Wednesday the 12th. After spending several hours fiddling with settings and app passwords through 2-Step Verification and Account Key, I went to bed only to find it working fine agains the following morning (the 13th). Then, mid-day on the 17th, it went down again. Today is the 20th and I'm still unable to sync, and not it's more than just the one account. A second account has stopped syncing as well.

 

For clarity, I'm seeing identical issues with Android Mail, Outlook, and Thunderbird. I can, however, access mail fine through webmail and Yahoo! Mail app for Android.

 

Despite other threads suggesting the IMAP problem has been solved (and no outages reported anywhere), it seems there are several of us continuing to see issues. I'll keep an eye glued to these forums and hopefully someone from Yahoo! will allay our concerns and tell us it is a hiccup due to the merger and everything will be sorted in a day or two. (As frustrating as that wait would be, at least then ther would be some answers.)

Established 'Hoo

Re: IMAP/POP not working

Here's what worked for me.

Go to outlook-->File-->Info-->Account Settings. Hit New, or click on the account you wish to modify. See at the bottom where it says "logon information-->Password"? Yahoo is rejecting your Yahoo Password! You need to generate an "app-specific password" to pass the first phase of the pop3 handshake. See below....

 

There are two phases to the pop3 test process. 

1) Log onto incoming mail server (POP3)

 

I got this to work by generating an app-specific password. I generated the password by enabling two-factor authentication (where Yahoo sends you a text message):

https://forums.yahoo.net/t5/Temporary-Errors/App-specific-password/m-p/115826#U115826

NB There is a bug, not sure if major or minor: When you generate a password for Outlook 2013 Desktop, it says the password was generated for Outlook Android. But it works for pop3 login (this phase).

 

2) Send test e-mail message:

I couldn’t get this to work til I input the following exact settings. Many of them are similar to the online recommendations but I had to get them exactly right:

 

(Notes: Windows 8.1 PC, 64-bit, Outlook 2013)

 

Pop and IMAP settings window

account type: pop3

Incoming mail server: pop.mail.yahoo.com

Outgoing mail server: smtp.mail.yahoo.com

User name: I just put the prefix, i.e. if your yahoo id is “me  at  yahoo  dot  com”, just put "me". No quote marks ;^D

Password: This is the app-specific (Outlook) password Yahoo Security generated for you in phase 1) above

Remember Password: Check

Require logon using Secure Password Authentication (SPA): Check

Automatically test account settings when Next is clicked: Check

Deliver new messages to: New Outlook Data File

(NB this is for me, setting up a NEW Pop3 account. Might be different if you're trying to fix an OLD Pop3).

 

Now click "More Settings" in lower right to open up the "Internet Email Settings" window. 

Outgoing Server tab:

My outgoing server (SMTP) requires authentication: Check

Log on using: Check

User Name: Full email address

Password: Use that third-party password again.

Remember Password: Check

Require Secure Password Authentication (SPA): Check

Log on to incoming mail server before sending mail: Do not check

 

Advanced tab:

Incoming server (POP3): 995

This server requires an encrypted connection (SSL): Check

Outgoing server (SMTP): 587

Use the following type of encrypted connection: Auto

Leave a copy of messages on the server: Check

Remove from server after xx days: Check

 

Some of these settings don't matter, but I have slavishly attempted to replicate EXACTLY what I did to get it to work. 

Main thing is to enable the 3rd party password in phase 1) above. That will log you into the POP server, then you can tweak the rest and solve phase 2).

 

New 'Hoo

Re: IMAP/POP not working

Will I be able to use IMAP in Outlook to check my basic free yahoo mail or do I need yahoo pro account?